Vite + G6 报错

阅读时间约 1 分钟

感谢来自 GitHub 用户 @wooodchen 的解决方案

如果你在使用 Vite + G6 构建时遇到类似下图的错误 image

请参考 GitHub Issue #2961 中的解决方案。

需要插件 rollup-plugin-node-rosolverollup-plugin-commonjs。虽然不能消除提示,但可以使用。 在 vite.config.js 中如下配置

import resolve from 'rollup-plugin-node-resolve'
import commonjs from 'rollup-plugin-commonjs'
// ...
export default defineConfig({
  plugin: [
    ...,
    resolve(),
    commonjs(),
    ...
  ]
})